Degraded Computer Use platform

Incident Report for Stilla

Resolved

Computer use is now fully operational.
Posted Jun 03, 2026 - 14:30 UTC

Investigating

We're investigating degraded performance and failures in computer task execution. This is caused by an ongoing outage at our upstream compute provider, Modal, whose auth subsystem is currently failing.

While this is ongoing, agent runs and other features that depend on computer execution may fail or be delayed. The rest of the app is unaffected.

We're monitoring Modal's recovery and will update this incident as the situation changes. No action is needed on your end.
Posted Jun 03, 2026 - 13:40 UTC
This incident affected: App (Computer Use).